FRUSTRADED w/ MK802 IIIS/BT

Forum to discuss the new Dual Core Rikomagic MK802 IIIS (bluetooth) Mini PC

Moderators: KEgg, twjordo, tatubias

FRUSTRADED w/ MK802 IIIS/BT

Postby mexdroid » Wed Jul 17, 2013 9:28 pm

I bought a MK802 IIIS about 6 or 7 weeks ago. since I received the mk802 iiis, i have experiencing different problems freezing, rebooting and applications not working as Netflix, YouTube, browsers, flash player and XBMC. The main reason I got this devices to make my flat TV a SMART-TV to be able to stream movies. I think I went thru every single topics and posts on the Rikomagic MK802 forum, some of the topic I read had the same issue with my mk802 iiis device. I did the suggested fixes but did not fix the problems.

Here is everything I done to try to fix these issues without luck.

Original OS version 4.1.1 (20130121): will freeze or reboot after couple of hours watching a movie or videos on browsers, Netflix or XMBC application. After couple of weeks found out there was a new OS version 4.2.2, downloaded the new version and follow the procedures to flash the new image on the mk802iiis.
Upgraded from 4.1.1 to 4.2.2 (20130618): Now with 4.2.2 version the freezing or rebooting will happen ones a day, I can leave with one’s day. But Netflix, Browsers (android browser or Firefox) and YouTube does not work the video and audio is out of synch. XBMC video and audio works fine on only one of my flat TV’s. I have different models of TV’s, if I plug the mk802 iiis on another TV’s the XBMC video works fine but the audio have a load pitch very annoying.

Now having different issues with both OS versions, found out there was another OS version 4.1.1 (20130428) so downgraded the OS.

Downgraded from 4.2.2 (20130618) to 4.1.1(20130428): I thought I had a winner with this version, but it got worst. After applying version 4.1.1 and installing the applications (Netflix, YouTube, Firefox and XBMC) and every single application work fine. But the freezing started again but this time will freeze after 20 to 30 minutes.

Ok now upgrading and downgrading the OS, I did more research and on the forum found out a site with different OS version. So I download the following version (20. NeoTV CR 2.0 20130601 JB 4.2.2 firmware (JB 4.2.2, custom version)) this version I did not experience the problems with freezing or rebooting. But Netflix, XBMC does not work. On Netflix the movies will not play (APPS & Browser), the XBMC does not open. YouTube works fine but not able to apply the new update.

Now with 4 different OS version and neither working, I went back and install version 4.1.1 (20130121) but now after the OS finish loading freezes after 5 or 10 minutes, I cannot configure or install anything.
I hope you understand why I’m very frustrated with this product. DID anyone know if RIKOMAGIC support or the programmers will read the topics on the forum?

Links where I downloaded the OS images.
http://www.rikomagic.com/en/download/do_1.html
http://www.rikomagic.co.uk/support.html
http://touchscreen-apps.blogspot.ro/201 ... n-one.html

Thanks for advance for any help on this issue and sorry for the long Topic,
mexdroid
 
Posts: 4
Joined: Tue Jul 16, 2013 4:47 pm

Re: FRUSTRADED w/ MK802 IIIS/BT

Postby vmishi » Thu Jul 18, 2013 2:50 pm

Same here, upgraded from 4.1.1. to 4.2.2. and no more series, no more youtube ... :(
I don't understand, how can be somebody so ignorant and amateur to give out such fw?
I think i will sell it if no repair comes in 1-2 weeks.
vmishi
 
Posts: 4
Joined: Wed Jul 17, 2013 9:13 pm

Re: FRUSTRADED w/ MK802 IIIS/BT

Postby mexdroid » Fri Jul 19, 2013 2:02 am

Well at least i found out is not just me. I was going to recommend this device to family and friends, but with all these issues im not sure. I HOPE RIKOMAGIC WILL HAVE A FIX ASAP, i will hate to waste $90.00 on this device. also i forgot to mention the AC adapter i'm using is 2amps. :twisted:
mexdroid
 
Posts: 4
Joined: Tue Jul 16, 2013 4:47 pm

Re: FRUSTRADED w/ MK802 IIIS/BT

Postby gs2004 » Mon Jul 22, 2013 5:48 pm

I have to agree with the OP here. I have tried almost all the firmwares and after a few days the unit just hangs on the boot animation from whichever firmware I use.

Really struggling to find a stable firmware as I need to use my gadget to work... ! :)
QX1 | MK802iiiS | MK802iii | MK802ii | CX-01 | Neo G4 | Topi T66
gs2004
 
Posts: 36
Joined: Wed Nov 28, 2012 9:51 am

Re: FRUSTRADED w/ MK802 IIIS/BT

Postby ramx2 » Mon Jul 22, 2013 6:54 pm

I'm sorry to tell you my friend, me an my pals ordered 5 mk802iiis 3 were working properly out of the box and the other two had your same symptoms my bad luck I had a faulty one, but I asked my friend to use his faulty one. He had different issues than yours and mine and reboots. He had issues which displays red and blue spots. Anyway I took it since it was faulty and he's not gonna use it anymore. When they released the 4.2.2 I flashed it and the spots disappeared and its working rock solid thank god :)

Flashing the faulty unit with different roms and cooked didn't resolve the reboots and the sudden crashes!

Ps: I'm using 2amp adapter whilst I tried the iPad 10W adapter and still with no avail ;)

I dismantled the faulty one and found out some soldering short issues.. This is really bad as if there's no quality control on the manufactured devices. The ironic issue is also with the MKIV wifi!! Come on Rikomagic you can do better than this! We are paying our dues and backstab in behind we deserve better product with better quality related to the software and the hardware ! I'm willing to buy the new one but I have doubts and fears since the last purchase and I don't want to end up with a faulty unit again!

Please check your products before selling it, otherwise we are gonna look for better ones.

Regards.
ramx2
 
Posts: 8
Joined: Mon Jan 07, 2013 6:10 am

Re: FRUSTRADED w/ MK802 IIIS/BT

Postby vmishi » Thu Jul 25, 2013 9:28 am

I just saw on rikomagic.com the new fw for mk802siii bt:
MK802IIIS8B Android 4.2 FW(20130722)

Im downloading it and tonight will try to "burn" it.

Hope they fixed the errors.
vmishi
 
Posts: 4
Joined: Wed Jul 17, 2013 9:13 pm


Return to Rikomagic MK802 IIIS Forum

Who is online

Users browsing this forum: No registered users and 4 guests