Page 14 of 14

Re: Upgrading/Updating the MK802 IV Firmware [tutorial]

PostPosted: Sun Nov 09, 2014 9:52 pm
by rkmgic
hey guys,

i upgraded from android 4.1 to 4.4 and everything was fine. Some points to take into account, or tips:

- leave Tv connected (HDMI port)
- when clicking on settings > Connect to pc , afterwards, the PC detects the device connected to USB and no image on TV
- the first time you will have to install drivers, the second time will automatically detect it correctly
- if the device (stick) isn't detected by USB press button switch in the software (batch tool)
- the notebook (PC) should be connected by USB to OTG port and will give the necesary voltage to the stick

If your notebook screen is 10" (like mine) you will need an external monitor to see the batch tool completely

the rkm keeps rebooting, i think this version (4.4) makes it consumes more power (amperes) and maybe my TV doesn't support such high current, so i connect the external power (DC) and everything goes well...

playing "SGNES lite" (super nintendo emulator) without problems with my Eurocase wireless controller
playing GT racing very well too

problems: my doubts...PLEASE HELP!

- can't use USB joystick center 2015, keeps asking for root rights and it says it doesn't have
- root checker says it has root access ¡?¡?
- When trying to install SuperSU it won't continue with the Binary installation....WHY?

Thanks for the support!!
Any answer will be appreciated!!!

Re: Upgrading/Updating the MK802 IV Firmware [tutorial]

PostPosted: Sun Nov 09, 2014 11:30 pm
by rkmgic
here i add some more info:

my MK802 is first gen. serial number 201305xx...
i downloaded "terminal emulator" and when i type:
Code: Select all
su -


then:

Code: Select all
su: uid 10078 not allowed to su
su: permission denied


so, i don't understand....i thought this firmware already has 'root' access... :(

please, can someone explain this to me? thank you very much!!!

is there a way to get old 4.1 firmware? i don't see any advantage of using 4.4.2 yet

Re: Upgrading/Updating the MK802 IV Firmware to run Amazon p

PostPosted: Thu Nov 13, 2014 9:02 am
by Lafrancon
Hello colleagues,

just for my information Iam trying to get some information from this forum as the German Rikomagic forum is down. I have the I would call it German version of Rikomagic stick MK802 IV S and MK802 IV S+ and tried to update them to Kit Kat according to the desciption which is available in youtube and described in your tutorial. But my version is not getting recognized on PC. Actual version is the Jelly Bean 4.2.
Do you see or does anybody any see chances to help me out or have an idea to upgrade this stick. I purchased it over Satkontor and they give the statement that there is no firmware available. But if the hardware is the MK802 IV S then it should be possible. I have also a MK802 IV S+ and this is also not open to be recognized. Please advice Thanks in advance. Reason for that is also to use it with Amazon Prime Instant Video whichis actually not working on this device. I hope that there is a chance to fix that with the update.

Or is there another option to run the amazon Prime Instant Video app on the device.

Re: Upgrading/Updating the MK802 IV Firmware [tutorial]

PostPosted: Thu Dec 04, 2014 11:58 am
by gaaboy
Hello guys.

I was trying to find the best FW for my one day old MK802 and finally I have f..kd up the device. I was trying to downgrade the device to 4.1.1 via batch tool but it showed me an error. Than I have disconnected the device and it is death now. :| I have tried to connect it on a proper way to many PCs but none of tham can recognize it. Even if I connect it to my LCD it doesn't startup. I can see that the device's blue led is on ...is it any possible way to get it up and running again?

Re: Upgrading/Updating the MK802 IV Firmware [tutorial]

PostPosted: Thu Dec 04, 2014 12:13 pm
by gaaboy
Hello guys!

I was trying to find the best FW for my one day old RKM802 IV and finally I have f....kd up the device. I tried to downgrade the FW to 4.1.1 via the batch tool...but it showed me an error...( I tried 4.4.2 and also 4.2.2. with success) than I disconnected the device and now it is totally death. No PC can recognize it and even when I connect it to my TV it doesn't start up. I can see that the blue led is on. Is there any way to get it up and running again?