Page 1 of 1

Picuntu stutters/hangs a lot, disk access / rknand_buffer?

PostPosted: Sat Nov 16, 2013 12:49 pm
by leadermontanus
Out of interest I have been trying to use this as my main PC for the past few days, from before I have a iMito MX1 running as a media server with Picuntu, so have some experience with speeds I can expect.

The core problem that renders it unrealistic to use is that a lot of the time (80% or so) it will stop for a few seconds before doing a task, The task can be the display of a sub menu in the main applications menu, installing an appliation, opening a web page from cache, etc.

So far I have tested the following, which leads to supect that disk writing is the issue:

    Is the CPU simply slower? No, once an application such as Gimp or NetBeans is open, it peforms very reasonably
    This is not a graphics issue, same problem with simple word processing
    Chromium is very slow when displaying pages, saying "Waiting for cache"
    Installing an application from the command line works OK for downloading, but unpacking, and in particular updating configuration takes 4 - 10 times longer that doing the same on the iMito MX1
    It is not Gnome (which comes as the pre-installed dekstop on the MK802IV), have same result with XFCE for instance

Looking in the process list (using top) I see that whenever it is slow rknand_buffer takes more than 10% of the CPU (usually low teens). I have not found any disk monitoring tools that work on Arm version of Ubuntu, so cannot say for sure what is accessing the disk... Looking in dmesg output I find:

Code: Select all
[536762.303803] [<c062da68>] (unwind_backtrace+0x0/0xe0) from [<bf009784>] (FlashReadErrorDump+0xb0/0xe4 [rk30xxnand_ko])
[536762.303930] [<bf009784>] (FlashReadErrorDump+0xb0/0xe4 [rk30xxnand_ko]) from [<bf00af70>] (FlashReadEnhanced+0x238/0x270 [rk30xxnand_ko])
[536762.304097] [<bf00af70>] (FlashReadEnhanced+0x238/0x270 [rk30xxnand_ko]) from [<bf00d6bc>] (FlashCopyProg+0x1ac/0x498 [rk30xxnand_ko])
[536762.304283] [<bf00d6bc>] (FlashCopyProg+0x1ac/0x498 [rk30xxnand_ko]) from [<bf00fcc0>] (ExchPageRemapClose+0x148/0x350 [rk30xxnand_ko])
[536762.304413] [<bf00fcc0>] (ExchPageRemapClose+0x148/0x350 [rk30xxnand_ko]) from [<bf00ff20>] (ExchBlkClose+0x58/0xc0 [rk30xxnand_ko])
[536762.304531] [<bf00ff20>] (ExchBlkClose+0x58/0xc0 [rk30xxnand_ko]) from [<bf0121b8>] (FtlWritePage+0x144/0x170 [rk30xxnand_ko])
[536762.304659] [<bf0121b8>] (FtlWritePage+0x144/0x170 [rk30xxnand_ko]) from [<bf012228>] (FtlCacheFree+0x44/0x58 [rk30xxnand_ko])
[536762.304778] [<bf012228>] (FtlCacheFree+0x44/0x58 [rk30xxnand_ko]) from [<bf013d04>] (FtlWrite+0x47c/0x4a0 [rk30xxnand_ko])
[536762.304981] [<bf013d04>] (FtlWrite+0x47c/0x4a0 [rk30xxnand_ko]) from [<bf013e4c>] (do_rknand_queue_request+0x68/0x70 [rk30xxnand_ko])
[536762.305094] [<bf013e4c>] (do_rknand_queue_request+0x68/0x70 [rk30xxnand_ko]) from [<bf014264>] (rknand_buffer_thread+0x410/0x930 [rk30xxnand_ko])
[536762.305182] [<bf014264>] (rknand_buffer_thread+0x410/0x930 [rk30xxnand_ko]) from [<c0671bbc>] (kthread+0x7c/0x88)
[536762.305233] [<c0671bbc>] (kthread+0x7c/0x88) from [<c06294c0>] (kernel_thread_exit+0x0/0x8)

Whether this is error on drive is difficult to say, most fsck type software must be run when drive is not mounted, but not usre if this can boot from the sdcard...

Does anyone else have the same issue and/or some ideas how to fix it? Or do I need a replacement unit? As I said, the iMito which is dual care only does not have this issue at all...


Re: Picuntu stutters/hangs a lot, disk access / rknand_buffe

PostPosted: Thu Nov 21, 2013 12:10 pm
by andykirby
maybe it would be worth recovering the device to see if it is something with the disk, PM me and I'll send you the instructions to get it back to factory settings.

I have to say we don't see these issues, the device seems snappy as ever, theres also no lag in Chromium.

of course, although quite unlikely it could be a hardware issue, in which case you can get a replacement.

Re: Picuntu stutters/hangs a lot, disk access / rknand_buffe

PostPosted: Sun Dec 01, 2013 8:11 pm
by leadermontanus
Finally found the time to reflash the firmware, and it seems to have cleared it up, even after (re)installing all the software I installed last time there is no more stuttering/pauses, so a much better experience... and now working out as a desktop/laptop replacement, very nice.

Thanks for friendly & useful response to this issue!


Re: Picuntu stutters/hangs a lot, disk access / rknand_buffe

PostPosted: Fri Jan 10, 2014 4:56 pm
by coro
Sorry if I am completely wrong, but..
I had faced troubles with SDCARD speeds, and expecially using Chrome/Chromium which went dead when I tried to deny access to temp directory by privileges..
I had a swapfile on sdcard image, and considering deadly low card write speeds (even at some UHS-I class "best sdcard _my_ money can buy" ), is was far from speed tunning. I have tried even great 200MB/s usb3 key but over usb2 it is limited as well..
I GUESS You were just waiting for swap operation, perhaps. For those "few seconds" after anyprogram run. If You do not want to swapoff that completely (but why?), perhaps just vm.swappiness can be set low.. But in fact, I do not know wheter swap is there in factory LE, at all..
Anyway, after killing swap file and setup Firefox which can accept no temp at all, computer I own (only MK802IIIs with heatsink) is pretty usable for browsing and general use. My internet seems to be faster than my sdcard.. :). Last point which needs some file storage is youtube.. I guess quad core with 2GB ram could find some space in ram for it as a workaround, but I own only dual core with 1GB and in addition my ram is heavily wasted, in image Ive got, for now...

Re: Picuntu stutters/hangs a lot, disk access / rknand_buffe

PostPosted: Mon Jan 27, 2014 7:37 pm
by tosiara

I also experience some issues with Picuntu 4.5 flashed to NAND:

Code: Select all
[    3.468928] gp_rknand_info = : 0xec8f2500
[    3.469062] request IRQ_NANDC irq , ret=0.........
[    3.469156] FlashCopyProgBuf1=0xc1607000
[    3.472513] ATime: 40 ns AHB: 148 timming: 1081
[    3.475699] No.1 FLASH INFO:45 de 94 93 76
[    3.488253] FlashReadRetry error!!,row = 40fa0
[    3.491538] data:80 00 00 00 00 00 00 00 00 20 00 00 00 00 00 00
[    3.494846] NAND INFO DUMP....ZYF
[    3.498146] AHB CLK: 148500
[    3.501454] FMCTL: 0x300 ; FMWAIT: 0x1081
[    3.504718] FLCTL: 0x100428 ; BCHCTL: 0x10 ; MTRANS_CFG: 0x1d0
[    3.507958] MTRANS_SADDR0: 0x0 ; MTRANS_SADDR1: 0x0
[    3.511252] MTRANS_STAT: 0x0 ; RANDMZ_CFG: 0x6ef6
[    3.514518] BCHST[0]: 0x400e007
[    3.517751] BCHST[1]: 0xe007
[    3.521200] BCHST[2]: 0xe007
[    3.524309] BCHST[3]: 0x4002
[    3.527342] BCHST[4]: 0x0
[    3.530464] BCHST[5]: 0x0
[    3.533526] BCHST[6]: 0x0
[    3.536449] BCHST[7]: 0x0
[    3.539610] [<c062da68>] (unwind_backtrace+0x0/0xe0) from [<bf009784>] (FlashReadErrorDump+0xb0/0xe4 [rk30xxnand_ko])
[    3.542910] [<bf009784>] (FlashReadErrorDump+0xb0/0xe4 [rk30xxnand_ko]) from [<bf00af70>] (FlashReadEnhanced+0x238/0x270 [rk30xxnand_ko])
[    3.546313] [<bf00af70>] (FlashReadEnhanced+0x238/0x270 [rk30xxnand_ko]) from [<bf00c1a8>] (ReloadFlashInfo+0x4c/0x110 [rk30xxnand_ko])
[    3.549734] [<bf00c1a8>] (ReloadFlashInfo+0x4c/0x110 [rk30xxnand_ko]) from [<bf016034>] (FlashInit+0xbf8/0xed0 [rk30xxnand_ko])
[    3.553206] [<bf016034>] (FlashInit+0xbf8/0xed0 [rk30xxnand_ko]) from [<bf016388>] (FtlInit+0x7c/0x158 [rk30xxnand_ko])
[    3.556920] [<bf016388>] (FtlInit+0x7c/0x158 [rk30xxnand_ko]) from [<bf0165f8>] (NandInit+0x194/0x330 [rk30xxnand_ko])
[    3.560543] [<bf0165f8>] (NandInit+0x194/0x330 [rk30xxnand_ko]) from [<bf016804>] (rk29nand_probe+0x70/0x210 [rk30xxnand_ko])
[    3.564222] [<bf016804>] (rk29nand_probe+0x70/0x210 [rk30xxnand_ko]) from [<c06235f4>] (do_one_initcall+0x90/0x160)
[    3.567954] [<c06235f4>] (do_one_initcall+0x90/0x160) from [<c0688450>] (sys_init_module+0x1698/0x1828)
[    3.571790] [<c0688450>] (sys_init_module+0x1698/0x1828) from [<c0628ac0>] (ret_fast_syscall+0x0/0x30)
[    3.576570] FlashReadRetry error!!,row = 407e0
[    3.580324] data:00 20 00 00 00 00 00 00 00 20 00 00 00 00 00 00
[    3.584193] ATime: 32 ns AHB: 148 timming: 1061
[    3.589145] FlashReadRetry error!!,row = 40000
[    3.592942] ATime: 38 ns AHB: 148 timming: 1081
[    3.597942] FlashReadRetry error!!,row = 40000
[    3.601770] ATime: 44 ns AHB: 148 timming: 1082
[    3.607023] FlashReadRetry error!!,row = 40000
[    3.611165] ATime: 32 ns AHB: 148 timming: 1061
[    3.614950] ATime: 38 ns AHB: 148 timming: 1081
[    3.619942] FlashReadRetry error!!,row = 40000
[    3.623599] ATime: 44 ns AHB: 148 timming: 1082
[    3.628846] FlashReadRetry error!!,row = 40000
[    3.632474] ATime: 38 ns AHB: 148 timming: 1081
[    3.636060] ATime: 44 ns AHB: 148 timming: 1082

Code: Select all
[    8.669490] rknand_buffer.c version: 4.38 20121130!
[    8.673622] 3 cmdlinepart partitions found on MTD device rk29xxnand
[    8.677595] Creating 3 MTD partitions on "rk29xxnand":
[    8.681459] 0x000000400000-0x000001400000 : "boot"
[    8.685910] 0x000001400000-0x000002400000 : "kernel"
[    8.690160] 0x000002400000-0x0001d6c00000 : "system"
[    8.699567] [<c062da68>] (unwind_backtrace+0x0/0xe0) from [<bf010884>] (GetRemap+0x174/0x1e4 [rk30xxnand_ko])
[    8.703597] [<bf010884>] (GetRemap+0x174/0x1e4 [rk30xxnand_ko]) from [<bf010b50>] (FtlSetSysProtAddr+0x28/0x2f4 [rk30xxnand_ko])
[    8.707739] [<bf010b50>] (FtlSetSysProtAddr+0x28/0x2f4 [rk30xxnand_ko]) from [<bf016928>] (rk29nand_probe+0x194/0x210 [rk30xxnand_ko])
[    8.711901] [<bf016928>] (rk29nand_probe+0x194/0x210 [rk30xxnand_ko]) from [<c06235f4>] (do_one_initcall+0x90/0x160)
[    8.716054] [<c06235f4>] (do_one_initcall+0x90/0x160) from [<c0688450>] (sys_init_module+0x1698/0x1828)
[    8.720414] [<c0688450>] (sys_init_module+0x1698/0x1828) from [<c0628ac0>] (ret_fast_syscall+0x0/0x30)
[    8.724566] [<c062da68>] (unwind_backtrace+0x0/0xe0) from [<bf010884>] (GetRemap+0x174/0x1e4 [rk30xxnand_ko])
[    8.728867] [<bf010884>] (GetRemap+0x174/0x1e4 [rk30xxnand_ko]) from [<bf010b80>] (FtlSetSysProtAddr+0x58/0x2f4 [rk30xxnand_ko])
[    8.733290] [<bf010b80>] (FtlSetSysProtAddr+0x58/0x2f4 [rk30xxnand_ko]) from [<bf016928>] (rk29nand_probe+0x194/0x210 [rk30xxnand_ko])
[    8.737938] [<bf016928>] (rk29nand_probe+0x194/0x210 [rk30xxnand_ko]) from [<c06235f4>] (do_one_initcall+0x90/0x160)
[    8.742420] [<c06235f4>] (do_one_initcall+0x90/0x160) from [<c0688450>] (sys_init_module+0x1698/0x1828)
[    8.746945] [<c0688450>] (sys_init_module+0x1698/0x1828) from [<c0628ac0>] (ret_fast_syscall+0x0/0x30)

The device currently works as server and hangs after 2-3 days

Should I re-flash Picuntu 4.5 and will it resolve anything?