No DTS Audio after Rev 2 Firmware update

Forum to discuss the Rikomagic MK802 Mini PC

Moderators: KEgg, twjordo, tatubias

Re: No DTS Audio after Rev 2 Firmware update

Postby KEgg » Tue Jul 31, 2012 5:33 pm

mistermentality wrote:Thanks, would be nice to have dts audio playback but I am wary of apps that ask for what seem to be unnecessary permissions. I shall try find a player that decodes dts.
Dave

Actually have got this to work for myself now. For some reason, still unsure why, the patch did not apply after running the install.. Also got the impression from a different forum that it would only work for stock player, which wasn't true. Anyway all I did was to decompress the apk and copy the libswa1.so to /system/libs/ folder and changed its permissions to be in line with the other files. I found a more positive post about it on the XBMC site, with a lot of people with the same concerns about its questionable security risks.
KEgg
 
Posts: 126
Joined: Wed Jun 27, 2012 12:12 pm
Location: United Kingdom

Re: No DTS Audio after Rev 2 Firmware update

Postby exodus » Tue Jul 31, 2012 8:46 pm

KEgg wrote:
mistermentality wrote:Thanks, would be nice to have dts audio playback but I am wary of apps that ask for what seem to be unnecessary permissions. I shall try find a player that decodes dts.
Dave

Actually have got this to work for myself now. For some reason, still unsure why, the patch did not apply after running the install.. Also got the impression from a different forum that it would only work for stock player, which wasn't true. Anyway all I did was to decompress the apk and copy the libswa1.so to /system/libs/ folder and changed its permissions to be in line with the other files. I found a more positive post about it on the XBMC site, with a lot of people with the same concerns about its questionable security risks.



It is the libswa1.so file that is updated? maybe we can upload it to dropbox and post instructions on how to copy/paste that over using the es file explorer instead of then apk? Sweet!! Thanks.
exodus
 
Posts: 72
Joined: Wed Jul 18, 2012 4:17 pm

Re: No DTS Audio after Rev 2 Firmware update

Postby mistermentality » Wed Aug 01, 2012 11:48 am

KEgg wrote:
mistermentality wrote:Thanks, would be nice to have dts audio playback but I am wary of apps that ask for what seem to be unnecessary permissions. I shall try find a player that decodes dts.
Dave

Actually have got this to work for myself now. For some reason, still unsure why, the patch did not apply after running the install.. Also got the impression from a different forum that it would only work for stock player, which wasn't true. Anyway all I did was to decompress the apk and copy the libswa1.so to /system/libs/ folder and changed its permissions to be in line with the other files. I found a more positive post about it on the XBMC site, with a lot of people with the same concerns about its questionable security risks.


Thankyou, I shall try that later. So I should be able to use root explorer or a similar app to copy the libswa1.so file and change its permissions so that they are the same as other files in the folder?

Dave
mistermentality
 
Posts: 31
Joined: Fri Jul 06, 2012 5:27 pm

Re: No DTS Audio after Rev 2 Firmware update

Postby KEgg » Wed Aug 01, 2012 1:01 pm

mistermentality wrote:Thankyou, I shall try that later. So I should be able to use root explorer or a similar app to copy the libswa1.so file and change its permissions so that they are the same as other files in the folder?

Dave


Yep.. correct sir.. also double check to make sure the owner is root.
KEgg
 
Posts: 126
Joined: Wed Jun 27, 2012 12:12 pm
Location: United Kingdom

Re: No DTS Audio after Rev 2 Firmware update

Postby avaya » Sat Sep 22, 2012 9:58 am

Hi folks!

I recently bought latest MK802 II and for now I'm almost satisfied with stock functionality & ROM features. Device is mainly used as media player for playing video files, audio files, radio streaming...

Everything works just fine except AC3 & DTS audio playback from stock player. I found an explanation on the internet that AC3 & DTS support was removed from rev2 firmware due to licence issues but I also found here an audio patch which should solve this problem. Has anyone tried this patch on MK802 II?

Is it safe to try? Can I mess something up? I'm a little bit worried because I don't have original firmware image...

As far as I can understand, it basically adds libswa1.so file inside /system/libs folder with proper permission settings and solves AC3/DTS playback problem under stock player (hardware decoding mode).

Thanks in advance!

Best regards,
Avaya
avaya
 
Posts: 9
Joined: Sat Sep 22, 2012 9:47 am

Re: No DTS Audio after Rev 2 Firmware update

Postby avaya » Wed Sep 26, 2012 3:59 pm

avaya wrote:Hi folks!

I recently bought latest MK802 II and for now I'm almost satisfied with stock functionality & ROM features. Device is mainly used as media player for playing video files, audio files, radio streaming...

Everything works just fine except AC3 & DTS audio playback from stock player. I found an explanation on the internet that AC3 & DTS support was removed from rev2 firmware due to licence issues but I also found here an audio patch which should solve this problem. Has anyone tried this patch on MK802 II?

Is it safe to try? Can I mess something up? I'm a little bit worried because I don't have original firmware image...

As far as I can understand, it basically adds libswa1.so file inside /system/libs folder with proper permission settings and solves AC3/DTS playback problem under stock player (hardware decoding mode).

Thanks in advance!

Best regards,
Avaya


Just found an answer to my question :-)

MK802 II already has this patch application preinstalled under stock firmware but it should be executed to make a patch work. So here are the steps:

1. open "Applications menu"
2. execute "Patch"
3. submit (simply press a button under executed application)
4. AC3/DTS hardware audio decoding should work (libswa1.so file is copied to /system/lib folder)
5. try to play several video files (*.avi, *.mkv) with AC3 or DTS audio, it should work without rebooting Android system

Best regards,
Avaya
avaya
 
Posts: 9
Joined: Sat Sep 22, 2012 9:47 am

Re: No DTS Audio after Rev 2 Firmware update

Postby lynckmeister » Sun Sep 15, 2013 5:40 pm

Hi Forum ,

I installed the patch as decribed before, but now, if i run a AC3 Video, there is no sound provided to my TV. ( Systemsounds from the OS are still provided .. )
The mk802II is connected via HDMI to the TV and the TV is sending the signal to my AC3 receiver... if I connect my Laptop to the TV playing the same video , I can receive the AC3 without any problems.

any suggestions ?
lynckmeister
 
Posts: 7
Joined: Sun Sep 15, 2013 5:35 pm

Re: No DTS Audio after Rev 2 Firmware update

Postby bevlin761 » Fri Jan 03, 2014 1:05 pm

I shall try find a player that decodes dts. I recently bought latest MK802 II and for now I'm almost satisfied with stock functionality & ROM features. Device is mainly used as media player for playing video files, audio files, radio streaming.
bevlin761
 
Posts: 25
Joined: Thu Nov 28, 2013 3:57 pm

Re: No DTS Audio after Rev 2 Firmware update

Postby bholdher » Sat Jan 04, 2014 6:00 am

If you load Rev 1 firmware DTS playback should work fine.
bholdher
 
Posts: 5
Joined: Sat Jul 21, 2012 8:48 am

Previous

Return to Rikomagic MK802 Forum

Who is online

Users browsing this forum: No registered users and 3 guests