Page 1 of 1

Headless debian on Rikomagic MK802

PostPosted: Sun Sep 07, 2014 7:07 pm
by ljones
Hello all! :-)

I'm largely trying to figure out how to get how to get a headless version of debian (this) version to run. On that site is a version of debian linux which when written to a micro SD card can turn an a10 device into a small low-powered server.

Unfortunatly I've not had all that much success. I understand that in that version btw that there is no video display output (the kernel needs to be replaced according to that website in order to have video). However on my rikomagic mk802 almost nothing happens.

First job was to try to determine using the built-in android on the mk802 device just what sort of CPU it was. There are 3 possibilities; A10, A13 and A10S. According to a program I found for android ("Cpu-Z") the CPU os an Allwinner A10 at 960(?) Mhz. The total ram is 813MB (presuaably really 1GB as some would be shared with the GPU/Video chip). The android version is 4.0.4.

I tried to follow the instructions btw on that website btw. I did not have any problems with decompressing the bz2 file from that website, it all seemed to go ok with out errors - if slowly. I then downloaded from this website a u-boot file; "u-boot-sunxi-a10_mid_1gb.tar.xz". I then uncompressed file and wrote the two files as per the instructions, e.g

Code: Select all
dd if=sunxi-spl.bin of=/dev/sdX bs=1024 seek=8
dd if=u-boot.bin of=/dev/sdX bs=1024 seek=40


I then powered up the mk802 and using a USB ethernet adapter tried to see if I could connect to the device. But it never showed up, never did anything. The only thing that did happen is that the blue powerlight was on and the mk802 device seemed to get quite warm. After this (and being concerned about the device running so warm!) I removed the SD card and checked to see if the device was still working, which it is (android still loads/starts up ok).

I then tried a different file ("u-boot-sunxi-mk802-1gb.tar.xz") and was met with the same results - the only difference was that the mk802 didn't seem to get so hot. x.x

The device dosen't seem to show up anywhere on my network. It is connected in via a USB ethernet adapter.

Am I right in thinking some of the allwinner/rikomagic devices could be "locked" in some way, i.e they don't run anything other than the burnt-in android on flash?

ljones

Re: Headless debian on Rikomagic MK802

PostPosted: Tue Sep 09, 2014 9:25 pm
by ljones
After a lot of poking around I discovered my device actually wasn't just a MK802, it is actually a MK802II. Or at least that is what it was sold as via ebay (I managed to look through the stuff I've bought off ebay and found it and the description there). However it still will not boot -- even if I use the correct file, "u-boot-sunxi-mk802ii" -- no joy at all, nothing. I've also tried using different USB ethernet adapters and microSD cards, still nothing.

ljones