Linux for MK802

Forum to discuss the Rikomagic MK802 Mini PC

Moderators: KEgg, twjordo, tatubias

Linux for MK802 II ?

Postby r28073 » Mon Aug 20, 2012 9:12 pm

Hi

What is the plan/schedule for SD images with Linux for the MK802 II?

Or any chance the MK802 v1 Linux images also work on MK802 II ?

Thanks
r28073
 
Posts: 8
Joined: Wed Aug 01, 2012 2:28 pm

Re: Linux for MK802

Postby MerlinGuy » Tue Aug 21, 2012 8:20 pm

I know most everyone wants the Ubuntu 12.04 with the UI but is there a distro of just the server with just the console mode similar to the default Ubuntu Server distro? I run a RPi as my web and svn server and I would love to use the MK802 as video and music server but I don't want to burn the memory on the graphical UI. Any suggestions? Is there a way to disable the UI server on the current distro?

Thanks

MG
MerlinGuy
 
Posts: 1
Joined: Tue Aug 21, 2012 3:25 pm

Re: Linux for MK802

Postby jbk » Thu Aug 23, 2012 5:26 pm

You can run it w/o X11. But if you do, you won't get any text console (arm linux doesn't have one).

In order to log into your device, you can setup adbd or use rndis. The first partition contains a start.bat which reads:

drivers\adb wait-for-device
drivers\adb forward tcp:22 tcp:22
drivers\adb shell /usr/local/bin/setDate "%DATE% %TIME%"

We use /usr/local/bin/start_adbd to provide a boot partition with device drivers and a startup script and the adb itself and start the adbd demon (you can find a static binary on your android partition) like this:

#"Starting adbd"
echo -n 18D1 >/sys/class/android_usb/android0/idVendor

echo -n 0 >/sys/class/android_usb/android0/enable
echo -n 0D02 >/sys/class/android_usb/android0/idProduct

if test $config = 1; then
echo -n "mass_storage,adb" >/sys/class/android_usb/android0/functions
else
echo -n "mass_storage" >/sys/class/android_usb/android0/functions
fi
echo "/dev/mmcblk0p1" >/sys/devices/virtual/android_usb/android0/f_mass_storage/lun/file

echo -n 1 >/sys/class/android_usb/android0/enable

chmod 777 /dev/android_adb
ln -fs /sys/class/android_usb/android0/enable /dev/android_adb_enable
chown root:adbd /sys/class/android_usb/android0/enable
chmod 660 /sys/class/android_usb/android0/enable


You could also use rndis, but it is unstable on Win7:

service udhcpd stop
killall adbd 2>/dev/null
echo -n 0 >/sys/class/android_usb/android0/enable

echo -n $id_vendor >/sys/class/android_usb/android0/idVendor
echo -n $id_product >/sys/class/android_usb/android0/idProduct
echo -n $wceis >/sys/class/android_usb/android0/f_rndis/wceis
echo -n "rndis" >/sys/class/android_usb/android0/functions
echo -n 224 >/sys/class/android_usb/android0/bDeviceClass
echo -n 1 >/sys/class/android_usb/android0/bDeviceSubClass
echo -n 32 >/sys/class/android_usb/android0/bDeviceClass
echo -n 3 >/sys/class/android_usb/android0/bDeviceProtocol
echo -n 1 >/sys/class/android_usb/android0/enable
ifup rndis0
service udhcpd start
jbk
 
Posts: 4
Joined: Wed Jul 18, 2012 2:53 pm

Re: Linux for MK802

Postby EnvyThisStuff » Thu Aug 23, 2012 9:20 pm

bert_mariani wrote:How does the SD card have to be formated ?
- Windows FAT32 ?
- Linux EXT4 ?

After it is formatted what should you see on it - files, partitions etc. (Windows, Linux)
After writting the Image file, what should you see on it - files, partitions etc? (Windows, Linux)

How do you identify if the "boot" program is on the SD card after the image is written.
Do you have to install the "boot" as a seperate step. Or does the Win32DiskImager or Linux "dd" command do it ?


I'm writing this from memory, but as I recall it, FAT32 it, and the dd's should do the rest. As to "what should you see on it" as I recall it, Android does not see it "properly" but you should be able to see if from say a LINUX system that you may be creating the card image from, and yes, you'll be able to see at various levels (fdisk, etc).
Run into a problem? Need ***Mini PC/MK802 services***?
(installing firmware, installing LINUX, getting/setting up SD cards, etc)
Contact us! http://www.EnvyThisStuff.com
EnvyThisStuff
 
Posts: 279
Joined: Tue Jun 26, 2012 12:57 am
Location: New York City

Re: Linux for MK802

Postby b3nn0 » Fri Aug 24, 2012 10:50 pm

Hey there,
I'm pretty new to all this stuff and I have a new A10 based tablet that nobody else seems to have.
Anyway, with a few modifications I was able to run your image. However, there are a few things that don't work as I'd like them to work.
Would it be possible that you post the .config you used for compiling the kernel? I'd love to use that as a base to get the rest to work. I already tried to get it up from scratch, but couldn't event get the display to light up..
Thanks!
b3nn0
 
Posts: 1
Joined: Fri Aug 24, 2012 10:47 pm

Re: Linux for MK802

Postby jacob019 » Sun Aug 26, 2012 12:33 am

jacob019
 
Posts: 2
Joined: Sun Aug 26, 2012 12:26 am

Re: Linux for MK802

Postby jacob019 » Sun Aug 26, 2012 12:37 am

jacob019
 
Posts: 2
Joined: Sun Aug 26, 2012 12:26 am

Re: Linux for MK802

Postby antpillage » Mon Aug 27, 2012 12:35 pm

roelfrenkema wrote:
fenyx wrote:Anyone having troubles with FW? When i try to configure iptables i got this message:

FATAL: Module ip_tables not found.
iptables v1.4.12: can't initialize iptables table `filter': No chain/target/match by that name
Perhaps iptables or your kernel needs to be upgraded.

Removed and reinstalled iptables with no luck.


It tells you the kernel is missing the module ip_tables so you need to check up why that module is missing. Here is a good guide to debugging that problem http://www.frozentux.net/iptables-tutor ... x5036.html



Has anyone had any luck resolving this issue? I can't seem to get the iptables module compiled into the kernel. I am running, Lubuntu with 'Linux miniand 3.0.36-t1+ #14 PREEMPT' (Rikomagic image). I installed iptables from the apt repositories, but it doesn't seem to install the module. Any help would be appreciated. http://www.frozentux.net/iptables-tutor ... x5036.html seems to only discuss the syntax for creating rules etc.

Note* I also installed iptables from source but that didn't have the iptables module.
antpillage
 
Posts: 1
Joined: Mon Aug 27, 2012 12:26 pm

Re: Linux for MK802

Postby fmg21 » Tue Aug 28, 2012 4:07 pm

Will it just be ok if I replace the miniand Lubuntu's kernel with this one's ?
fmg21
 
Posts: 1
Joined: Tue Aug 28, 2012 4:05 pm

Re: Linux for MK802

Postby kookcmoi » Wed Aug 29, 2012 2:17 pm

Hello,

The lubuntu img file does not uncompress with 7-Zip. It generates an error message in the 7 zip software.
I trid to download again multiple times to be sure the download was not corrupt but it appears not to be that.
Is there another place to get this IMG file that work ?

thanks,
kookcmoi
 
Posts: 1
Joined: Wed Aug 29, 2012 2:13 pm

PreviousNext

Return to Rikomagic MK802 Forum

Who is online

Users browsing this forum: No registered users and 5 guests