I'm not able to change the Software Source server

Forum to discuss the new MK902II LE RK3288 Quad Core Linux Mini PC.

Moderators: KEgg, twjordo, tatubias

I'm not able to change the Software Source server

Postby el_gallo_azul » Mon Jan 26, 2015 5:06 am

Software & Updates > "Download from:" > "Other..." > Can't be set to the correct server. See attached screenshot (filename is "2 - No download servers listed.png").

Normally, in Lubuntu and Ubuntu, I set this to my ISP's mirror so that it's faster and doesn't count towards my data quota.
Attachments
2 - No download servers listed.png
2 - No download servers listed.png (10.59 KiB) Viewed 3482 times
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Re: I'm not able to change the Software Source server

Postby giupmat » Wed Jan 28, 2015 1:47 pm

Try this:
Code: Select all
sudo nano /etc/apt/sources.list

You can edit settings directly in the config file.
giupmat
 
Posts: 30
Joined: Wed Dec 03, 2014 10:56 am

Re: I'm not able to change the Software Source server

Postby el_gallo_azul » Thu Feb 05, 2015 11:31 pm

Thanks. I've updated that file now. There are two things that are still a bit quirky:

1. A normal run of "software Updater" still ends with an error message to "check your internet connection", even though internet connection is fine; and

2. I see that Ubuntu software > "Download from" is still uk.archive.ubuntu.com, despite the fact that I have ## all of those lines in the file, and the only options are "Main server", "uk.archive.ubuntu.com"" and "Other..." although "Other..." still appears an empty list as shown in the screenshot that I attached to this thread.
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Re: I'm not able to change the Software Source server

Postby giupmat » Fri Feb 06, 2015 9:35 am

Sorry mate, but I don't know deeply how Ubuntu works.
apt is a Debian-community son and I think that this configuration is only change you need to do.
For the connection issue: do you have a proxy in your LAN?
First of all check:
Code: Select all
cat apt/history.log
cat apt/term.log

and if you see some errors try to understand where's the problem :)

To set a proxy, try to check this path
Code: Select all
/etc/apt/apt.conf.d/

and if you don't see a file named proxy [30proxy or 80proxy or somewhat], try to execute this as root:
Code: Select all
touch /etc/apt/apt.conf.d/80proxy
chmod 744 /etc/apt/apt.conf.d/80proxy
echo 'Acquire::http::Proxy "http://user:pass@proxy.example.com:8080/";' > /etc/apt/apt.conf.d/80proxy
giupmat
 
Posts: 30
Joined: Wed Dec 03, 2014 10:56 am

Re: I'm not able to change the Software Source server

Postby el_gallo_azul » Sun Feb 08, 2015 6:36 am

Code: Select all
user@RIKOMAGIC:~$ cat apt/history.log
cat: apt/history.log: No such file or directory

Code: Select all
user@RIKOMAGIC:~$ cat apt/term.log
cat: apt/term.log: No such file or directory


I haven't been able to find a file "history.log" anywhere.

And then...

Code: Select all
user@RIKOMAGIC:~$ sudo touch /etc/apt/apt.conf.d/80proxy
[sudo] password for user:
user@RIKOMAGIC:~$ sudo chmod 744 /etc/apt/apt.conf.d/80proxy
user@RIKOMAGIC:~$ sudo echo 'Acquire::http::Proxy "http://user:pass@proxy.example.com:8080/";' > /etc/apt/apt.conf.d/80proxy
bash: /etc/apt/apt.conf.d/80proxy: Permission denied
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Re: I'm not able to change the Software Source server

Postby giupmat » Tue Feb 10, 2015 11:10 am

Let me restate that you need to configure a proxy for apt only if you already have a proxy server that conveys your network traffic.
To perform your system changes I suggest you to raise up your permissions by typing:
Code: Select all
sudo su

instead of re-use sudo on each command. Let me know...
Code: Select all
sudo su
touch /etc/apt/apt.conf.d/80proxy
chown root /etc/apt/apt.conf.d/80proxy
chmod 744 /etc/apt/apt.conf.d/80proxy
echo 'Acquire::http::Proxy "http://user:pass@proxy.example.com:8080/";' > /etc/apt/apt.conf.d/80proxy


Ops! Sorry, my mistake in logs path:
Code: Select all
cat /var/log/apt/history.log
cat /var/log/apt/term.log
giupmat
 
Posts: 30
Joined: Wed Dec 03, 2014 10:56 am

Re: I'm not able to change the Software Source server

Postby el_gallo_azul » Wed Feb 11, 2015 9:49 am

As far as I know, there is no proxy server. I don't have one, but I don't know enough about my ISP's system configuration, and its implications, to know for sure.

I'll look in /var/log/apt/ for history.log and term.log on the MK902IILE computer tomorrow.
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Re: I'm not able to change the Software Source server

Postby el_gallo_azul » Thu Feb 12, 2015 4:08 am

Code: Select all
user@RIKOMAGIC:~$ cat /var/log/apt/history.log

Start-Date: 2015-02-11  08:48:28
Commandline: aptdaemon role='role-commit-packages' sender=':1.78'
Upgrade: libgssapi-krb5-2:armhf (1.12+dfsg-2ubuntu4.2, 1.12+dfsg-2ubuntu5.1), libkrb5-3:armhf (1.12+dfsg-2ubuntu4.2, 1.12+dfsg-2ubuntu5.1), krb5-locales:armhf (1.12+dfsg-2ubuntu4.2, 1.12+dfsg-2ubuntu5.1), libk5crypto3:armhf (1.12+dfsg-2ubuntu4.2, 1.12+dfsg-2ubuntu5.1), chromium-browser-l10n:armhf (40.0.2214.94-0ubuntu0.14.04.1.1068, 40.0.2214.111-0ubuntu0.14.04.1.1069), chromium-browser:armhf (40.0.2214.94-0ubuntu0.14.04.1.1068, 40.0.2214.111-0ubuntu0.14.04.1.1069), bluez-cups:armhf (4.101-0ubuntu13, 4.101-0ubuntu13.1), libbluetooth3:armhf (4.101-0ubuntu13, 4.101-0ubuntu13.1), libkrb5support0:armhf (1.12+dfsg-2ubuntu4.2, 1.12+dfsg-2ubuntu5.1), bluez-alsa:armhf (4.101-0ubuntu13, 4.101-0ubuntu13.1), bluez:armhf (4.101-0ubuntu13, 4.101-0ubuntu13.1), chromium-codecs-ffmpeg-extra:armhf (40.0.2214.94-0ubuntu0.14.04.1.1068, 40.0.2214.111-0ubuntu0.14.04.1.1069)
End-Date: 2015-02-11  08:48:53

Start-Date: 2015-02-12  13:29:53
Commandline: apt-get upgrade
Upgrade: gir1.2-gnomebluetooth-1.0:armhf (3.8.2.1-0ubuntu4.1, 3.8.2.1-0ubuntu4.2), nautilus-data:armhf (3.10.1-0ubuntu9.5, 3.10.1-0ubuntu9.6), libpam-gnome-keyring:armhf (3.10.1-1ubuntu4.1, 3.10.1-1ubuntu4.2), libgnome-bluetooth11:armhf (3.8.2.1-0ubuntu4.1, 3.8.2.1-0ubuntu4.2), procps:armhf (3.3.9-1ubuntu2.1, 3.3.9-1ubuntu2.2), xfdesktop4:armhf (4.11.6-1ubuntu1, 4.11.8-0ubuntu0.1), gnome-system-tools:armhf (3.0.0-3ubuntu4, 3.0.0-3ubuntu4.1), libnautilus-extension1a:armhf (3.10.1-0ubuntu9.5, 3.10.1-0ubuntu9.6), gnome-keyring:armhf (3.10.1-1ubuntu4.1, 3.10.1-1ubuntu4.2), gnome-bluetooth:armhf (3.8.2.1-0ubuntu4.1, 3.8.2.1-0ubuntu4.2), unity-greeter:armhf (14.04.10-0ubuntu1, 14.04.11-0ubuntu1), xfdesktop4-data:armhf (4.11.6-1ubuntu1, 4.11.8-0ubuntu0.1), libprocps3:armhf (3.3.9-1ubuntu2.1, 3.3.9-1ubuntu2.2), libp11-kit-gnome-keyring:armhf (3.10.1-1ubuntu4.1, 3.10.1-1ubuntu4.2)
End-Date: 2015-02-12  13:30:55
user@RIKOMAGIC:~$

and

Code: Select all
user@RIKOMAGIC:~$ cat /var/log/apt/term.log   

Log started: 2015-02-11  08:48:28
(Reading database ... 113685 files and directories currently installed.)
Preparing to unpack .../libk5crypto3_1.12+dfsg-2ubuntu5.1_armhf.deb ...
Unpacking libk5crypto3:armhf (1.12+dfsg-2ubuntu5.1) over (1.12+dfsg-2ubuntu4.2) ...
Preparing to unpack .../libgssapi-krb5-2_1.12+dfsg-2ubuntu5.1_armhf.deb ...
Unpacking libgssapi-krb5-2:armhf (1.12+dfsg-2ubuntu5.1) over (1.12+dfsg-2ubuntu4.2) ...
Preparing to unpack .../libkrb5-3_1.12+dfsg-2ubuntu5.1_armhf.deb ...
Unpacking libkrb5-3:armhf (1.12+dfsg-2ubuntu5.1) over (1.12+dfsg-2ubuntu4.2) ...
Preparing to unpack .../libkrb5support0_1.12+dfsg-2ubuntu5.1_armhf.deb ...
Unpacking libkrb5support0:armhf (1.12+dfsg-2ubuntu5.1) over (1.12+dfsg-2ubuntu4.2) ...
Preparing to unpack .../chromium-browser-l10n_40.0.2214.111-0ubuntu0.14.04.1.1069_all.deb ...
Unpacking chromium-browser-l10n (40.0.2214.111-0ubuntu0.14.04.1.1069) over (40.0.2214.94-0ubuntu0.14.04.1.1068) ...
Preparing to unpack .../chromium-codecs-ffmpeg-extra_40.0.2214.111-0ubuntu0.14.04.1.1069_armhf.deb ...
Unpacking chromium-codecs-ffmpeg-extra (40.0.2214.111-0ubuntu0.14.04.1.1069) over (40.0.2214.94-0ubuntu0.14.04.1.1068) ...
Preparing to unpack .../chromium-browser_40.0.2214.111-0ubuntu0.14.04.1.1069_armhf.deb ...
Unpacking chromium-browser (40.0.2214.111-0ubuntu0.14.04.1.1069) over (40.0.2214.94-0ubuntu0.14.04.1.1068) ...
Preparing to unpack .../libbluetooth3_4.101-0ubuntu13.1_armhf.deb ...
Unpacking libbluetooth3:armhf (4.101-0ubuntu13.1) over (4.101-0ubuntu13) ...
Preparing to unpack .../krb5-locales_1.12+dfsg-2ubuntu5.1_all.deb ...
Unpacking krb5-locales (1.12+dfsg-2ubuntu5.1) over (1.12+dfsg-2ubuntu4.2) ...
Preparing to unpack .../bluez_4.101-0ubuntu13.1_armhf.deb ...
bluetooth stop/waiting
Unpacking bluez (4.101-0ubuntu13.1) over (4.101-0ubuntu13) ...
Preparing to unpack .../bluez-alsa_4.101-0ubuntu13.1_armhf.deb ...
Unpacking bluez-alsa:armhf (4.101-0ubuntu13.1) over (4.101-0ubuntu13) ...
Preparing to unpack .../bluez-cups_4.101-0ubuntu13.1_armhf.deb ...
Unpacking bluez-cups (4.101-0ubuntu13.1) over (4.101-0ubuntu13) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up libkrb5support0:armhf (1.12+dfsg-2ubuntu5.1) ...
Setting up libk5crypto3:armhf (1.12+dfsg-2ubuntu5.1) ...
Setting up libkrb5-3:armhf (1.12+dfsg-2ubuntu5.1) ...
Setting up libgssapi-krb5-2:armhf (1.12+dfsg-2ubuntu5.1) ...
Setting up chromium-codecs-ffmpeg-extra (40.0.2214.111-0ubuntu0.14.04.1.1069) ...
Setting up chromium-browser (40.0.2214.111-0ubuntu0.14.04.1.1069) ...
Setting up chromium-browser-l10n (40.0.2214.111-0ubuntu0.14.04.1.1069) ...
Setting up libbluetooth3:armhf (4.101-0ubuntu13.1) ...
Setting up krb5-locales (1.12+dfsg-2ubuntu5.1) ...
Setting up bluez (4.101-0ubuntu13.1) ...
bluetooth start/running, process 2879
Setting up bluez-alsa:armhf (4.101-0ubuntu13.1) ...
Setting up bluez-cups (4.101-0ubuntu13.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...
Log ended: 2015-02-11  08:48:53

Log started: 2015-02-12  13:29:53
(Reading database ... 113685 files and directories currently installed.)
Preparing to unpack .../libprocps3_1%3a3.3.9-1ubuntu2.2_armhf.deb ...
Unpacking libprocps3:armhf (1:3.3.9-1ubuntu2.2) over (1:3.3.9-1ubuntu2.1) ...
Preparing to unpack .../libp11-kit-gnome-keyring_3.10.1-1ubuntu4.2_armhf.deb ...
Unpacking libp11-kit-gnome-keyring:armhf (3.10.1-1ubuntu4.2) over (3.10.1-1ubuntu4.1) ...
Preparing to unpack .../gnome-keyring_3.10.1-1ubuntu4.2_armhf.deb ...
Unpacking gnome-keyring (3.10.1-1ubuntu4.2) over (3.10.1-1ubuntu4.1) ...
Preparing to unpack .../libpam-gnome-keyring_3.10.1-1ubuntu4.2_armhf.deb ...
Unpacking libpam-gnome-keyring:armhf (3.10.1-1ubuntu4.2) over (3.10.1-1ubuntu4.1) ...
Preparing to unpack .../procps_1%3a3.3.9-1ubuntu2.2_armhf.deb ...
Unpacking procps (1:3.3.9-1ubuntu2.2) over (1:3.3.9-1ubuntu2.1) ...
Preparing to unpack .../libgnome-bluetooth11_3.8.2.1-0ubuntu4.2_armhf.deb ...
Unpacking libgnome-bluetooth11 (3.8.2.1-0ubuntu4.2) over (3.8.2.1-0ubuntu4.1) ...
Preparing to unpack .../gir1.2-gnomebluetooth-1.0_3.8.2.1-0ubuntu4.2_armhf.deb ...
Unpacking gir1.2-gnomebluetooth-1.0 (3.8.2.1-0ubuntu4.2) over (3.8.2.1-0ubuntu4.1) ...
Preparing to unpack .../gnome-bluetooth_3.8.2.1-0ubuntu4.2_armhf.deb ...
Unpacking gnome-bluetooth (3.8.2.1-0ubuntu4.2) over (3.8.2.1-0ubuntu4.1) ...
Preparing to unpack .../libnautilus-extension1a_1%3a3.10.1-0ubuntu9.6_armhf.deb ...
Unpacking libnautilus-extension1a (1:3.10.1-0ubuntu9.6) over (1:3.10.1-0ubuntu9.5) ...
Preparing to unpack .../nautilus-data_1%3a3.10.1-0ubuntu9.6_all.deb ...
Unpacking nautilus-data (1:3.10.1-0ubuntu9.6) over (1:3.10.1-0ubuntu9.5) ...
Preparing to unpack .../unity-greeter_14.04.11-0ubuntu1_armhf.deb ...
Unpacking unity-greeter (14.04.11-0ubuntu1) over (14.04.10-0ubuntu1) ...
Preparing to unpack .../xfdesktop4_4.11.8-0ubuntu0.1_armhf.deb ...
Unpacking xfdesktop4 (4.11.8-0ubuntu0.1) over (4.11.6-1ubuntu1) ...
Preparing to unpack .../xfdesktop4-data_4.11.8-0ubuntu0.1_all.deb ...
Unpacking xfdesktop4-data (4.11.8-0ubuntu0.1) over (4.11.6-1ubuntu1) ...
Preparing to unpack .../gnome-system-tools_3.0.0-3ubuntu4.1_armhf.deb ...
Unpacking gnome-system-tools (3.0.0-3ubuntu4.1) over (3.0.0-3ubuntu4) ...
Processing triggers for libglib2.0-0:armhf (2.40.2-0ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for gconf2 (3.2.6-0ubuntu2) ...
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for mime-support (3.54ubuntu1.1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Setting up libprocps3:armhf (1:3.3.9-1ubuntu2.2) ...
Setting up libp11-kit-gnome-keyring:armhf (3.10.1-1ubuntu4.2) ...
Setting up gnome-keyring (3.10.1-1ubuntu4.2) ...
Installing new version of config file /etc/xdg/autostart/gnome-keyring-ssh.desktop ...
Installing new version of config file /etc/xdg/autostart/gnome-keyring-gpg.desktop ...
Setting up libpam-gnome-keyring:armhf (3.10.1-1ubuntu4.2) ...
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up procps (1:3.3.9-1ubuntu2.2) ...
procps stop/waiting
Setting up libgnome-bluetooth11 (3.8.2.1-0ubuntu4.2) ...
Setting up gir1.2-gnomebluetooth-1.0 (3.8.2.1-0ubuntu4.2) ...
Setting up gnome-bluetooth (3.8.2.1-0ubuntu4.2) ...
Setting up libnautilus-extension1a (1:3.10.1-0ubuntu9.6) ...
Setting up nautilus-data (1:3.10.1-0ubuntu9.6) ...
Setting up unity-greeter (14.04.11-0ubuntu1) ...
Setting up xfdesktop4-data (4.11.8-0ubuntu0.1) ...
Setting up xfdesktop4 (4.11.8-0ubuntu0.1) ...
Setting up gnome-system-tools (3.0.0-3ubuntu4.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.5) ...
Log ended: 2015-02-12  13:30:55
user@RIKOMAGIC:~$


No errors there.
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Re: I'm not able to change the Software Source server

Postby giupmat » Fri Feb 13, 2015 3:38 pm

Uhm... There's an hard problem to solve, I don't know how I can help you without access to the machine. Sorry, mate.
Have you tried to check your dmesg?
giupmat
 
Posts: 30
Joined: Wed Dec 03, 2014 10:56 am

Re: I'm not able to change the Software Source server

Postby el_gallo_azul » Sat Feb 14, 2015 3:07 am

No. I don't even know what that is!

The computer works, and seems able to update software (with some errors along the way), and I have quite a large monthly internet data limit, so I suppose this will just remain as an 'undocumented feature'.
el_gallo_azul
 
Posts: 17
Joined: Fri Jan 16, 2015 12:22 am

Next

Return to Rikomagic / Cloudsto MK902II LE RK3288 Quad Core Linux Mini PC

Who is online

Users browsing this forum: No registered users and 1 guest