A10 Media PC+ Feedback

Forum to discuss the A10 Media PC

Moderators: KEgg, twjordo, tatubias

A10 Media PC+ Feedback

Postby engelgw » Fri Oct 26, 2012 1:03 pm

Here is a short feedback after having tested the A10 Media PC+ few days.

The device was delivered by DHL one week after ordering. I had to pay a 19 euros customs tax (France).
It was my fist time with an Android device. My objective is to turn the TV of my 80' years old mother into a smart one at a limited cost, allowing her to access without effort internet radio and TV channels, online pictures web album (with the possibility to copy pictures over a SD card), Skype. I have nearly succeeded, all the above operations being controlled by the remote control provided (with only 9 buttons of it actually).
My findings:
The video part of the A/V output isn't good enough (but HDMI rocks...). The system is stable. I had some problems at the beginning with the audio (no audio and the parameters service was closing as soon as I was trying to access the audio parameters. I do not have anymore this problem but this still remains a mystery for me.
The built-in media player is crap, unable to read most of my media files. Installing MX player clearly solves this issue.
By choosing the right parameters, an app like Justpictures! can be used to display and manage pictures only with the remote control.
Skype is working but the system doesn't recognize the webcam Logitech C270 I have. So currently, on way video chat is working.
I plan to test some others webcams if I can put my hands on some other models. It might be also possible that the current firmware version doesn't allow to plug a webcam, I don't know... If someone has identified a webcam model which is working properly on a A10, please tell me.

To conclude, I am rather satisfied with this device. It would be perfect with a properly functioning webcam. ;)
engelgw
 
Posts: 1
Joined: Fri Oct 26, 2012 11:56 am

Re: A10 Media PC+ Feedback

Postby quiffhanger » Tue Oct 30, 2012 9:36 pm

Mine just arrived.

The device is nice - really snappy. Very easy to hook up and all just works.

Unfortunately, the two major apps I bought it for: iPlayer & Netflix dont work! The iPlayer app just opens a browser and gives such bad quality video I cant even watch it. The Netflix app just refuses to launch. It's a real shame as the device is clearly capable of much more: it plays 720p fine from Youtube. Haven't tested 1080p is only 720p.

Of course this isn't the fault of the device but it's a real shame - I'm hoping they get fixed at some point...

-ross
quiffhanger
 
Posts: 1
Joined: Tue Oct 30, 2012 9:26 pm


Return to A10 Media PC Forum

Who is online

Users browsing this forum: No registered users and 2 guests