(probably) clone mk802ii and wifi

Forum to discuss the Rikomagic MK802 II Mini PC

Moderators: KEgg, twjordo, tatubias

(probably) clone mk802ii and wifi

Postby tomboc73 » Sat Feb 09, 2013 8:31 am

Hi,
I received a cheap (probably a clone?) mk802ii. With android (4.0.4) all fine, but with linaro I cannot see the wifi.
So first question is how I should be able to find the internal model (dmesg dos not seem to help); only hint I found is from "lsusb" which says

Bus 003 Device 002: ID 0bda:8179 Realtek Semiconductor Corp.

the other strange message in dmesg is

[wifi]: select sdio wifi: swl-n20 !!

is this the wifi? and then which is the model?

I would like to know if anyone
1) knows a linux which works with this
OR
2) can point me to a driver

also, the system claims a eth0, 10/100 Mbit, with a valid HW address (wemac in dmesg...)... what can it be?

thanks a lot

By the way, being a cheap clone (32$ included free shipping), I am not pissed off at all ... android works with 1080p + market out of the box ...

ciao ciao

tom
tomboc73
 
Posts: 9
Joined: Fri Dec 28, 2012 3:50 pm

Re: (probably) clone mk802ii and wifi

Postby tomboc73 » Sun Feb 10, 2013 8:31 am

Looking into Android's dmesg, I read

usbcore: registered new interface driver rtl8188eu

I guess I can simply follow these instructions:

http://www.rikomagic.co.uk/forum/viewto ... 3299#p9313

right?

thanks

tom
tomboc73
 
Posts: 9
Joined: Fri Dec 28, 2012 3:50 pm

Re: (probably) clone mk802ii and wifi

Postby quandt » Tue Jun 11, 2013 3:32 am

Did you figure this out at all?

My experience is the following:

1) Assuming your kernel has the device's abilities turned on, if not, you need to get a kernel with proper support for the hw/wifi in question. Or of course build one with the right devices turned on. So far, I believe the kernels I've been using have the realteks turned on (or ones I've built I make sure to turn them on).

2) other issues (more common) seem to be related to the boot up code, or script.bin file located in the root directory. There are specific device details stored in these files (before) the kernel even sees anything. I'm sorry but I can't recall the right links in this forum towards waht script.bin's to use and other variants towards getting the boot process to recognize/turn on all the availble hw for a given device. But yes, the info is here on this forum somewhere.

Now my issue, which might be similar to yours. I have a mk802ii "white" which works like a charm, wifi works, etc (ie with my preferred script.bin, and appropriate sunxi-spl.bin u-boot.bin files loaded in the boot sectors of my sd card). I also have what looks the like the same mk802ii but black. I too think this mk802ii is a cheap knock-off but different in some manner, ie I can't seem to get the wifi up on the black ones. Any other similar results from you or others reading this board, and a known fix? I've yet to pull out my magnifiying glass to see what wifi part is on this black unit. The boards look the same, but I see different part numbs on the a10 (which raises questions in my mind).
quandt
 
Posts: 3
Joined: Tue Nov 06, 2012 2:32 am


Return to Rikomagic MK802 II Forum

Who is online

Users browsing this forum: No registered users and 2 guests