RECOVERY IMG MK802-III HERE!!!!

Forum to discuss the Dual Core Rikomagic MK802 III Mini PC

Moderators: KEgg, twjordo, tatubias

Re: RECOVERY IMG MK802-III HERE!!!!

Postby matg » Wed Dec 26, 2012 2:59 pm

Riot wrote:Didn't though i ever needed the IMG but i 'm glad u posted this, got my MK802III working again :D
After applying quick reboot app, my device would only show the animation on start but then wouldn't load android anymore.

maybe some additional tips for u guys:
1. the first box in batch tool means language, click on it and select the 2nd option. Now u will see everything in English.
2. install usb driver from location: \RockusbDriver. (i read some articles earlier about installing driver from the exe file Livesuit, lost allot of time get this installed properly and flashing with the batch tool only fails)
3. upgrade in batch tool fails, after installing (the right) driver reboot laptop (i got: win7 x64), u can leave the MK802III connected and start the batch tool again press upgrade and there it goes.


How do you install the drivers? Where do the files go.

I'm a Mac user so not use to Windows 7

EDIT: I worked it out, Pin trick then when to Computer> Manage and install for the unknown device.

Now working again!
matg
 
Posts: 31
Joined: Mon Oct 22, 2012 6:31 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby swedski » Wed Jan 02, 2013 8:06 am

Slinky wrote
by slinky_41 » Wed Dec 19, 2012 3:35 am

I figured it out. What I did was use the 6 and 7 pin trick then I did the flash mode trick. With the two pins next to the nand chip. The hit the restore and from there it ran the firmware restore.


I did do this but keep getting the error message listed below. Tried it on three different computers. WHat two pins next to the NAND chip are you describing? Is it the 6-7 pins or are there other pins to hit?

Mark



20:20:51 552 **********Restore Start Total<1>**********
20:20:51 562 <Layer 1-1-3-2-4> Download Boot Start
20:20:53 505 <Layer 1-1-3-2-4> Download Boot Success
20:20:53 512 <Layer 1-1-3-2-4> Wait For Maskrom Start
20:20:54 153 <Layer 1-1-3-2-4> Wait For Maskrom Success
20:20:54 158 <Layer 1-1-3-2-4> Test Device Start
20:20:54 165 <Layer 1-1-3-2-4> Test Device Success
20:20:54 170 <Layer 1-1-3-2-4> Check Chip Start
20:20:54 175 <Layer 1-1-3-2-4> Check Chip Success
20:20:54 179 <Layer 1-1-3-2-4> Get FlashInfo Start
20:20:54 182 <LAYER 1-1-3-2-4> INFO:FlashInfo: 0 0 0 0 0 1 4 0 32 0 0
20:20:54 186 <Layer 1-1-3-2-4> Get FlashInfo Success
20:20:54 190 <Layer 1-1-3-2-4> Prepare IDB Start
20:20:54 192 <LAYER 1-1-3-2-4> ERROR:PrepareIDB-->No Found 1st Flash CS
20:20:54 196 <Layer 1-1-3-2-4> Prepare IDB Fail
swedski
 
Posts: 13
Joined: Wed Oct 17, 2012 4:56 am

Re: RECOVERY IMG MK802-III HERE!!!!

Postby strumpan » Sat Jan 05, 2013 12:17 am

slinky_41 wrote:I figured it out. What I did was use the 6 and 7 pin trick then I did the flash mode trick. With the two pins next to the nand chip. The hit the restore and from there it ran the firmware restore.


Where do i find the 6 and 7 pin? Found the two pins by the nand by looking at this image:
http://img201.imageshack.us/img201/6673/reseting.jpg
found in this thread:
http://www.rikomagic.co.uk/forum/viewtopic.php?f=9&t=3300 this thred..

And where is the reset? what do i miss :oops:

edit..
Fixed it,.
strumpan
 
Posts: 5
Joined: Fri Jan 04, 2013 7:14 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby AvE » Tue Jan 08, 2013 10:37 pm

I have a similar problem:

I have put my device in recovery mode with the 2 pins next to the nand chip.
I installed the drivers on my PC (Win7 X64) Also tried WinXP 32.
The device shows in RK Batch Tool 1.5
So far so good.
When I want to restore the firmware I get:

Loading firmware...
Loading firmware Finished.
**********Restore Action**********
**********Restore Start Total<1>**********
<Layer 2-1-2> Download Boot Start
<Layer 2-1-2> Download Boot Success
<Layer 2-1-2> Wait For Maskrom Start
<Layer 2-1-2> Wait For Maskrom Success
<Layer 2-1-2> Test Device Start
<Layer 2-1-2> Test Device Success
<Layer 2-1-2> Check Chip Start
<Layer 2-1-2> Check Chip Success
<Layer 2-1-2> Get FlashInfo Start
<Layer 2-1-2> Get FlashInfo Success
<Layer 2-1-2> Prepare IDB Start
<Layer 2-1-2> Prepare IDB Success
<Layer 2-1-2> Download IDB Start
<Layer 2-1-2> Download IDB Fail
**********Restore Done Success<0> Fail<1> Time<4119>ms**********

Tried different PC's and different USB ports.

Is it possible to get out of recovery mode or are there any other options?
AvE
 
Posts: 2
Joined: Tue Jan 08, 2013 10:30 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby guluka » Wed Jan 09, 2013 5:40 pm

Hi there,

Can someone help me?
Where is the reset button? MK802III
I am waiting for response.
guluka
 
Posts: 11
Joined: Fri Jan 04, 2013 5:20 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby mk802iii-user » Fri Jan 11, 2013 12:03 am

-have the mini usb cable connected as well together with the usb to pc


Having a blonde moment. In many posts it suggests to connect to the PC with the enclosed USB cable. Only a micro-USB -> USB cable was enclosed. When connected it powers up the MK802iii, but PC does not recognise device. To connect USB on MK802iii to USB on PC you need a USB-male to USB-male adapter. These are not usual. Can you please confirm if that is what I need to flash the device with finless 1.7 (or recovery)?

http://www.ebay.co.uk/itm/USB-Gender-Ch ... 0727006025

Thanks.

EDIT: Yep; don't do complex new stuff late at night. Simple answer is "use the enclosed USB cable". Don't connect anything to the main MK802iii USB port, but switch on USB on the MK802iii in Settings>USB>Connect to PC.

After an evening of play now have Finless 1.7 installed without problems (and I am sure can do recovery also if needed). Problem solved.
mk802iii-user
 
Posts: 1
Joined: Tue Jan 01, 2013 10:05 am

Re: RECOVERY IMG MK802-III HERE!!!!

Postby mcargue » Sat Jan 19, 2013 11:46 am

Yay!
I broke my device trying to flash a other (1.6GHz) Finless ROM to my Rikomagic, because I was on the 1.2GHz.
Because I did this:
Image

I totally forgot to do "reboot bootloader" on the terminal app.. That was why the flashing program gave me a message about "cannot flashboot" or whatever... I totally forgot about this. :P

But luckily they made this Recovery tool... so guys...
Never bridge those two pins...

Bridge the pin 6-7 on the nand chip. :)
mcargue
 
Posts: 20
Joined: Fri Oct 26, 2012 9:19 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby guluka » Sun Jan 20, 2013 8:33 pm

Hi there,
Why writes the flash tool the following?

By the "reboot to flash mode":
"device cannot do flash mode because it is not msc device"

And at "nand erase" writes:
"download boot fail"
Shall I tick something by the nfs or ram tab?

The batch tool has an error too:
By the upgrade and restore write that download boot failed

So here I am. Trash? Or is there any solution? My eyes are hurting from the translations and from the wathching millions of pages. Can you help me please? The device is MK802III. I know it's not matching to this topic, but I'm really desperate yet....

Thank You!
guluka
 
Posts: 11
Joined: Fri Jan 04, 2013 5:20 pm

Re: RECOVERY IMG MK802-III HERE!!!!

Postby wapvirus » Thu Jan 24, 2013 12:36 am

Here is my Tip instead of struggling with Chinese translation in the RKBatchTool look at the files and you will see a file called config.ini open it with notepad and you will see
#选择工具语言:Selected=1(中文);Selected=2(英文)
[Language]
Kinds=2
Selected=1
LangPath=Language\


Change the selected =1 line from 1 to 2 it should look like this :
#选择工具语言:Selected=1(中文);Selected=2(英文)
[Language]
Kinds=2
Selected=2
LangPath=Language\


save the file and open the RKBatchTool it will now all be in english :D
My Device: MK802III
ROM: 2dark4u/Finless custom ROM version 1.7a
Peripherals: 7Port USB Hub : Logitech K700 Keyboard : Buffalo 1TB HDD : 16 GB SD : Xbox360 Controller :Logitech HD Webcam C270 :5 Amp Power Supply
wapvirus
 
Posts: 16
Joined: Sun Jan 06, 2013 3:18 am

Re: RECOVERY IMG MK802-III HERE!!!!

Postby alin_afronie » Mon Mar 11, 2013 8:13 am

iCan't find theat pins for recovery...I have seen a lot of images but all aof them are different.Which is the right one?i have mk802III ...i shorted the 6 and 7 pins from nand flash and nothing is happening!How can i start the recovery?Such a time wasting only for a recovery buttn that dont exist,Please helm me.My Rikomagic dont start anymore and I'm so said!
alin_afronie
 
Posts: 13
Joined: Sun Mar 10, 2013 11:16 pm

PreviousNext

Return to Rikomagic MK802 III Forum

Who is online

Users browsing this forum: No registered users and 2 guests