Cannot install apk files!

Forum to discuss the Dual Core Rikomagic MK802 III Mini PC

Moderators: KEgg, twjordo, tatubias

Cannot install apk files!

Postby EvFlow » Tue Jan 08, 2013 11:07 pm

Recently I have got this little marvelous gadget. All works fine and I am very happy with it.

However, there is a problem that is making me crazy. When I dowload an apk and I try to install it, the button 'install' is deactivated and I cannot click in it. I have read tons of forums and, in phones, the problem is caused by apps installed named 'Screen filter', 'Screen locker', etc. You only have to kill them, and then all works fine.

I have looked for apps named like that in my MK802 III and I have not found anyone. I have killed all possible proccesses and even I have made a hard reset. Nothing have worked.

If anyone of you could help me I will be grateful forever. I swear that situation is driving me mad. I even cannot install XBMC!.

Thank you in advance
Posts: 2
Joined: Tue Jan 08, 2013 10:52 pm

Re: Cannot install apk files!

Postby twjordo » Wed Jan 09, 2013 1:08 pm

this is most unusual...lets go over a few things

1) go to settings/development and make sure "unknown sources" is tic'd on

2) is it rooted ???

3) what firmware or rom are you running ???
mk802IV w/ mk702IIair mouse ~ mk802+ 1gb ram 4 gb storage ~ mk802II 1gb ram 4gb storage ~ mk802IIIs 1gb ram 8gb storage with 4port usb running wireless mouse/kboard and red samurai bt gaming controller ~ mk808b 1gb ram 8gb storage
check out TechKnow
Posts: 406
Joined: Fri Jul 06, 2012 6:07 am
Location: tennessee usa

Re: Cannot install apk files!

Postby EvFlow » Wed Jan 09, 2013 9:44 pm

I can add more information: I've been exhaustively "googling" and I've found there can be a solution by stopping/clearing data of a proccess called "Media Storage". I've stopped the proccess, cleared data and inhabilitated it and, amazingly, The "Install" button has woked once. I've been able to install one apk.

Suddenly, that was all. The button is still frozen in any other apk. No matter what I do with the service. I've rebooted the system, the proccess starts, I do it the same way, but nothing happens.

I need Sherlock Holmes...
Posts: 2
Joined: Tue Jan 08, 2013 10:52 pm

Re: Cannot install apk files!

Postby HoKe » Thu Jan 10, 2013 5:58 pm

Hi, I solved this for me by using arrow keys to navigate to the Install button.
after that I used Enter key and voala. installation in progress.
good luck!
Posts: 1
Joined: Sun Dec 30, 2012 11:00 pm

Re: Cannot install apk files!

Postby yunusaj » Sat Jan 12, 2013 3:24 pm


I am having the same problem. Tried every possible method. restarted the device, tried to install it through app installer, even tried to look for the screen lock killer functions mentioned above.
Its frustating.

Can anyone help please

Device: Rikomagic MK802iii 8GB
Anrdoid version: 4.1.1
Kernel version 3.08+

Input method. Tried wireless mouse, and droidmote.

:x :x :x :x :x :x :x
Posts: 1
Joined: Sat Jan 12, 2013 3:20 pm

Re: Cannot install apk files!

Postby mr tripps » Fri Jun 28, 2013 12:21 am

has anybody solved this issue? i have read almost every post and spent days googling the problem. nothing works. all i want to do is install apks.
mr tripps
Posts: 1
Joined: Fri Jun 28, 2013 12:15 am

Return to Rikomagic MK802 III Forum

Who is online

Users browsing this forum: Google [Bot] and 5 guests