Order your MK802 from here Official Rikomagic Website

MK802 III stopped working on first day

Forum to discuss the Dual Core Rikomagic MK802 III Mini PC

Moderators: KEgg, twjordo, tatubias

MK802 III stopped working on first day

Postby Lone_Soul » Thu Jan 10, 2013 3:27 am

Hey,

I bought the MK802 III through eBay and received it today. After some fumbling around with the device, I managed to get it working on the TV, through connecting the device to both the HDMI and USB ports on the TV.
After I was done, I clicked the power button on the Air Mouse that came with it, and it appeared to go to some sort of "screen off" mode.
I then left for some other business, and when I came back, the device was completely shut off, and pressing the power key did nothing.
I've tried various solutions such as checking different HDMI and USB cables, connecting to an electrical outlet instead of a TV, connecting the device directly to the HDMI slot in the TV without a cable and even checking all of those on a different TV.
It appears that I've somehow, without doing anything, bricked the device, as far as I can tell.

After that, I've also tried download the firmware update on an SD Card, but then I noticed that you actually need to connect the device to a TV and see the dialog window to download the firmware update if your device isn't working. Really?
Also, why isn't there any hard-reset button on the device? Nearly all of the cheapest MP3 and MP4 players have a little reset button, unless I'm missing something.
I don't mean to bash at the device, because for the little time that I had it working, I enjoyed it quite a bit, but I don't see how doing nothing can kill the device.

I'm not really interested in soldering or welding the internal parts of the device, because I'm planning to return the device as new as possible if there's no solution that doesn't require tearing the device's guts open.
I'm hoping there's a way to apply the firmware update without a TV, or fixing the problem without updating the firmware, unless the device needs to be shipped back to the seller.
I will appreciate any help on this matter :)
Lone_Soul
 
Posts: 2
Joined: Thu Jan 10, 2013 3:07 am

Re: MK802 III stopped working on first day

Postby shishir332 » Thu Jan 10, 2013 11:06 pm

Not really sure when you say 'screen off' mode. Is there anything coming on your TV screen when you plug the device in and power it on ? As far as I understand you don't need to press the power button of your air mouse remote to turn the device on - it automatically switches on when you plug the power source.

Take another shot at it If you are willing to open up the device and flash it as described here - viewtopic.php?f=9&t=2725

Cheers,
shishir332
 
Posts: 37
Joined: Tue Dec 18, 2012 2:15 pm

Re: MK802 III stopped working on first day

Postby Lone_Soul » Thu Jan 10, 2013 11:38 pm

Thanks for the reply!
The air mouse I was speaking of is this one here:
Image

I pressed the red power key on the top left, right next to the Escape key, which made the device go to a screensaver or sleep mode, I suppose. When I came back later, I found it to be turned off, and pressing the power key didn't work. What I did after that is all listed above, on my first post.

I suppose the last thing to resort to is to open the device up. I have a few questions before I do so, though.
I wanted to know what's the easiest way to open it up, since there's no screws or bolts in it, and it appears to just be clipped into place by hand, and might break with force. I suppose pulling the TF card slot's cover would work?
Also, I was wondering if there's a visual representation of what the pins look like on the MK802 III. I found this on another thread, http://www.rikomagic.co.uk/forum/viewtopic.php?f=9&t=3300, I suppose that's that?

Please forgive me for the tediousness, I'm just planning to send it back to the seller in good shape if I can't fix it myself.

Thanks for any replies!

EDIT: It appears that I've fixed the device!
If anyone experiences this issue in the future, what I did was connecting the device to a Windows 7 computer (didn't work on Windows 8), and then I installed the driver from the firmware recovery folder on the laptop. I then tried using the batch tool to recover the firmware but got an error (probably because I had to open up the device and flash it). But for some reason, when I connected it back to the PC, even without flashing it, it started working again!

Thanks for the help!
Lone_Soul
 
Posts: 2
Joined: Thu Jan 10, 2013 3:07 am


Return to Rikomagic MK802 III Forum

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests