Page 1 of 1

Wifi issue after recover/update

PostPosted: Thu Jan 23, 2014 8:48 am
by tokaz
Hi all.

I'm stock at a problem here. I have a Rikomagic MK802III.
For almost a year the wifi works without any problems then one the it suddenly deactivated and i cannot enable it again. (A lot of other people have this issue as far as i could read)
I've tried to update via FT card and i tried to recover and last i tried to update to the newest firmware 4,2 jellybean (viewtopic.php?f=9&t=4753)

After that i still got the issue, it cannot enable the wifi. Then i asked my colleague who is a former radio mechanic if he could see anything on the print. He couldn't but tried anyway to re solder the wifi connection on the print/board. Then we tried to turn it on and pling! wifi was enabled. I could see the wifi routers SSID and i could connect and put in the password, but i will not connect. After that i tried to reboot. Now I'm back at the old problem with no possibility to enable the wifi.

So I'm kind a stuck here. Anyone have the same problem and maybe know how to solve it? :)

Have a nice day! Thanks in advance! :D

Re: Wifi issue after recover/update

PostPosted: Tue Feb 04, 2014 12:49 pm
by larryking6458
Great post. I will be going through some of these issues as well..

Re: Wifi issue after recover/update

PostPosted: Fri Mar 21, 2014 3:37 am
by jimwang
Had exact problem. Tried a lot firmware, no luck. Then tried the recovery image from http://www.rikomagic.co.uk/forum/viewtopic.php?f=9&t=2725, Wifi come back. But still cannot upgrade, have to stick with this version.